1. Tired of not being able to see links? Want to chat with other members? Need help?

PlusEMU Help & Support

Discussion in 'Habbo Help & Support' started by Sledmore, Feb 8, 2017.

  1. Epicrobzer

    Epicrobzer New Member

    [ Want to see this link? Register ! ]
    --- Double Post Merged, Feb 12, 2017, Original Post Date: Feb 12, 2017 ---
     
  2. JynX

    JynX Depression is merely anger without enthusiasm.

    Try using [ Want to see this link? Register ! ] as a few people have had issues with other SWF decompilers saying it's corrupt when it's not.
     
    yoyok likes this.
  3. Epicrobzer

    Epicrobzer New Member

    thanks, will try :)
     
  4. localhostxpxd

    localhostxpxd New Member

  5. LukeOx

    LukeOx PeakRP.com

    You need to enable it in your external variables.
     
  6. Epicrobzer

    Epicrobzer New Member

    Is it possible badges aint working? Because I can't give myself a badge true the give command and i can't get a badge trough database
     
  7. maxam2000

    maxam2000 New Member

    Could anyone help me with this problem? [ Want to see this link? Register ! ]
     
    SupahCookie likes this.
  8. SupahCookie

    SupahCookie Member

    i have this..
    (SCREEN)
    [ Want to see this link? Register ! ]

    nothing is loading... kinda wierd? right?

    [ Want to see this link? Register ! ]
    external_variables...
    --- Double Post Merged, Feb 14, 2017, Original Post Date: Feb 14, 2017 ---
    i have the same..
     
  9. Dan3212

    Dan3212 Member

    Have you got data in your badge_definitions table? That might be the problem you're trying to solve.

    If not then post. (If you are unaware, if you are trying to give yourself your very own badge you imported, add it to your badge_definitions table)
     
  10. Epicrobzer

    Epicrobzer New Member

    this was the problem indeed, fixed it :)
     
  11. Zaka

    Zaka Programmer

    Top Poster Of Month

    I did set up the emulator and all when developing on my CMS, and it seems I have the same issue, could be the swfs or some error in the items in the database, I don't really know.
     
  12. Haidyn

    Haidyn PeakRP.com

    It's likely links in your external variables, if you manage to get online and things aren't loading 9 times outta 10 it's your vars.
     
    Sledmore and Zaka like this.
  13. Epicrobzer

    Epicrobzer New Member

    Override External Vars?
     
    Sledmore likes this.
  14. Paylee

    Paylee Member

    After adding the pet interaction stuff from developement, then I get this error; ItemData does not contain a definition for BehaviourData and no extension method accepting a first argument of type could be found (are you missing a using directive or an assembly reference?)
     
  15. KylePr0zZ

    KylePr0zZ Member

    Hey @Sledmore I was on the client last night with #Release1 it was fully working perfectly fine but then when I came back on it the next day (Not changed or messed with anything) and when I loaded it, it doesn't go past 76% and I get a critical exception with this below!:

    Code:
    Bug during user login: System.FormatException: Input string was not in a correct format.
       at System.Number.StringToNumber(String str, NumberStyles options, NumberBuffer& number, NumberFormatInfo info, Boolean parseDecimal)
       at System.Number.ParseInt32(String s, NumberStyles style, NumberFormatInfo info)
       at System.Convert.ToInt32(String value)
       at Plus.HabboHotel.Rooms.RoomData.Fill(DataRow Row) in C:\Users\Kyle\Desktop\Emulator\HabboHotel\Rooms\RoomData.cs:line 89
       at Plus.HabboHotel.Rooms.RoomManager.FetchRoomData(Int32 RoomId, DataRow dRow) in C:\Users\Kyle\Desktop\Emulator\HabboHotel\Rooms\RoomManager.cs:line 400
       at Plus.HabboHotel.Users.UserDataManagement.UserDataFactory.GetUserData(String SessionTicket, Byte& errorCode) in C:\Users\Kyle\Desktop\Emulator\HabboHotel\Users\UserData\UserDataFactory.cs:line 178
       at Plus.HabboHotel.GameClients.GameClient.TryAuthenticate(String AuthTicket) in C:\Users\Kyle\Desktop\Emulator\HabboHotel\GameClients\GameClient.cs:line 108
    
    Could it be a bug with your SSOTicket Patch? cause like I said above it was working perfectly fine the day before, it's very strange.
     
  16. Bjork

    Bjork Member

    Nop, seems to be an issue with the value of
    Code:
    RoomBlockingEnabled = Convert.ToInt32(Row["room_blocking_disabled"].ToString());
    on RoomData.cs:89
     
  17. Velaski

    Velaski winner

    This piece of code makes no sense. Was probably an accident. I assume RoomBlockingEnabled is a boolean. So change that to:
    PHP:
    RoomBlockingEnabled PlusEnvironment.EnumToBool(Row["room_blocking_disabled"].ToString());
     
  18. KylePr0zZ

    KylePr0zZ Member

    That didn't work, I fixed it, for some reason there was no value for room_blocking_disabled so I put it to 0 in rooms table and it's working now. I only created a room and it put a no value instead of 0 or 1, it must not have a default value in db or emulator must not set it.
     
  19. Velaski

    Velaski winner

    Ohhh it uses 0 and 1. Thought it would use True/False
     
  20. Bjork

    Bjork Member

    It was a bool in the past, Sledmore (i guess) changed it in the first release of his PlusEmu last year.
     

Share This Page

Loading...