Cloudflare SSL & HTTPS Issue

Status
Not open for further replies.

nightmarewilliam

New Member
Feb 19, 2023
21
4
I connected my domain and server via Cloudflare to create Habbo retro, but there is such a problem. I can easily log in to the site with HTTP://, but it still gives a warning that it is not secure. When I log in with HTTPS://, it gives a security warning again and this time it takes me to the page shown below instead of the site page.
 

Attachments

  • screenshot.PNG
    screenshot.PNG
    24.1 KB · Views: 33

nightmarewilliam

New Member
Feb 19, 2023
21
4
Since this looks like it isn't a local hotel, don't use XAMPP for production.

Have a look at this tutorial:
i know itss not very convenient to use XAMPP but the other way seems too complicated and i might get more errors. for now, it will be enough if i solve this "Index of/" problem
 

Liam

Super Moderator
Staff member
FindRetros Moderator
Apr 10, 2013
1,192
717
i know itss not very convenient to use XAMPP but the other way seems too complicated and i might get more errors. for now, it will be enough if i solve this "Index of/" problem
The tutorial for IIS is in 3 parts, which makes it less complicated, and will get your hotel up and running if you follow the steps.

If you persist on using XAMPP, make sure your site is linked to the public folder. Google how to do this.
 

nightmarewilliam

New Member
Feb 19, 2023
21
4
The tutorial for IIS is in 3 parts, which makes it less complicated, and will get your hotel up and running if you follow the steps.

If you persist on using XAMPP, make sure your site is linked to the public folder. Google how to do this.
finally i found out why it shows the "Index Of/" page when connected via https. in the "httpd-ssl.conf" apache files, the "htdocs" folder is specified instead of the "public" folder for the "DocumentRoot" setting. when i changed this to the public directory, the problem was solved. thank you very much for your help. now all that remains is for the site to display an unsafe warning.
 

Liam

Super Moderator
Staff member
FindRetros Moderator
Apr 10, 2013
1,192
717
finally i found out why it shows the "Index Of/" page when connected via https. in the "httpd-ssl.conf" apache files, the "htdocs" folder is specified instead of the "public" folder for the "DocumentRoot" setting. when i changed this to the public directory, the problem was solved. thank you very much for your help. now all that remains is for the site to display an unsafe warning.
Is it enabled in .env and Cloudflare?
 
Status
Not open for further replies.

Users who are viewing this thread

Top