1. Tired of not being able to see links? Want to chat with other members? Need help?

Two problems, one simple one hard

Discussion in 'Habbo Help & Support' started by icecafe, Feb 15, 2017.

Thread Status:
Not open for further replies.
  1. icecafe

    icecafe Member

    First off let me state that I am using PlusEMU (Sledmore) and RevCMS on IIS.

    So im more focused on the problem of customs not working. Tips post edit is to just to clear somethings up and re-state the problem.

    What I have done:
    1. Added the SWF files to my hof_furni folder. ( I made sure that they did in fact have a grafics tag.
    2. Added the furni data that was given with them.
    3. Added the furni to the two db's. (Furni and catalog_items)
    4. When adding them to the db's I made sure that the sprite_id matches the ID in the furni data that corresponds to the correct furni.
    5. I ran the commands :update_furni and :update_catalog after I booted my hotel back up, because I stop my hotel when applying updates.

    The outcome is that the furni is still invisible. My hope is that someone can give me furni data/SQL/SWF that are 100% guaranteed to work on sled's plus emu so I can see if it's an a swf issue or something else.
     
    Last edited: Feb 24, 2017
  2. Zaka

    Zaka Programmer

    Top Poster Of Month

    You can follow the development of PlusEmu, Sledmore is working on it now again. And the furni id in the database must match the one in furnidata
     
  3. icecafe

    icecafe Member

    @Zaka
    They do match.

    [ Want to see this link? Register ! ]
     
  4. Zaka

    Zaka Programmer

    Top Poster Of Month

    Not the ID column, it's another one, forgot the name of it
     
  5. icecafe

    icecafe Member

    @Zaka
    sprite_id, it seems to be what others are linked to however they are still invisible :x
    --- Double Post Merged, Feb 16, 2017, Original Post Date: Feb 15, 2017 ---
    Upon more testing. I got the HC Custom Pack from retro ripper. I looked at the other items in furnidata and saw the common ID was the sprite_id. Now that I learned this I set each sprite id to the matching id in the furnidata. Still no luck. The good news is that the HC Customs Pack came with and without the tag. With the tag just disconnects me and without dosnt. I'm not sure if this will help, but thank you all for the help so far!
     
  6. Zaka

    Zaka Programmer

    Top Poster Of Month

    Yes exactly, the sprite_id is the one that has to be in furnidata + database. Nowadays furnidata.xml is used and you have to have the GFX tag, and there is some added line into the actual SWF itself. Remember to also clean you cache before accessing the hotel, and use the command :update items and :update catalogue I think it is, not sure tho.
     
  7. icecafe

    icecafe Member

    Using ones with tags just disconnect me, why is that? How do I add the tags myself?
     
  8. Zaka

    Zaka Programmer

    Top Poster Of Month

    You would have to basically decompile the SWF file, make the changes and then compile it again.
     
  9. icecafe

    icecafe Member

    Do you have a cracked sothink swf decompiler or can I use a different one?
    Can you also provide an example of the tag and or a guide on how to add one for plusemu.
     
  10. Zaka

    Zaka Programmer

    Top Poster Of Month

    No I don't, I don't mess around with SWF files :p
     
  11. icecafe

    icecafe Member

    You got a skype I could possably add you at?
     
  12. Zaka

    Zaka Programmer

    Top Poster Of Month

    Yeah, but as I said, I dont mess around with SWF's so therefore my help would be useless in this case
     
  13. icecafe

    icecafe Member

    Well I found a furni editor added the tag and its still invisible. :x
     
  14. Zaka

    Zaka Programmer

    Top Poster Of Month

    could it be cache?
     
  15. icecafe

    icecafe Member

    I have no idea, but I am using IIS and I did clear my cache before going on so I will wait and see.
    Could you just type a list on how to add them so I can make sure I did it properly. I bet its some minor detail that I overlooked. SWF has tag, furnidata in, ids match furnidata no idea what else to do.
     
  16. Zaka

    Zaka Programmer

    Top Poster Of Month

    As I've said two times already, I don't really deal with SWF's, but you add the item to hof_furni, you add the row to furnidata, and you use the same ID as sprite_id in the furniture table of the database.
     
    icecafe likes this.
  17. icecafe

    icecafe Member

    I understand. I just wanted to make sure I was at least installing them right. Thanks for the help so far!
    --- Double Post Merged, Feb 17, 2017, Original Post Date: Feb 16, 2017 ---
    Someone suggested it could be related to IIS htaccess? Is their any truth to this?
     
    Zaka likes this.
  18. yoyok

    yoyok Member

    Before post things like this, check first other threads for help. This question is already answered many times on devbest. It's not hard to fix the issue.
     
  19. icecafe

    icecafe Member

    @yoyok If you could please link me a thread like that it would be a lot of help.
    All of the threads I found relate to not having the graphics tag, which I have done. I also have: added the furni to both DB's (Furni/Catalog_items), added the furni to furnidata, added the SWF files to the hof_furni and used :update items / :update catalog in game.
     
  20. yoyok

    yoyok Member

    PM your Skype i'll help you out
     
Thread Status:
Not open for further replies.

Share This Page

Loading...