revcms client for nitro?

boz

don daddy
Mar 23, 2021
108
32
Hi i've been off the retro scene for awhile now.... obviously coming back to no flash is mind boggling me. i've set up everything just barring the client (nitro.php) i've got the file but if i goto access the file its just a blank screen. I'll post the .php file below.

<html lang="en"> <head> <meta charset="utf-8"> <title>Ubbo - Hotel</title> <base href="nitro-assets/ "> <meta name="viewport" content="width=device-width, initial-scale=1.0"> <link rel="shortcut icon" type="image/x-icon" href="favicon.ico"> <link rel="stylesheet" href="app/tpl/skins/custom-habbo/client/client.css"> </head> <body> <script> var NitroConfig = { configurationUrl: 'localhost/configuration.json?9999999999', sso: "<?php $base = ""; for($i = 1; $i <= 3; $i++): { $base = $base . rand(0,99); $base = uniqid($base); } endfor; $base = $base . ""; $ThisPDO = $pdo->query('UPDATE users SET auth_ticket = ? WHERE id = ?', [$base, $_SESSION['id']]); echo $base; ?>" }; </script> <script src="localhost/runtime.js" defer></script><script src="localhost/polyfills.js" defer></script><script src="localhost/vendor.js" defer></script><script src="localhost/main.js" defer></script></body> </html>
 

Solid

Member
May 1, 2012
101
21
this is what i use with my revcms and nitro and works perfect:
<?php $userMaster = mysql_fetch_array(mysql_query("SELECT * FROM `users` WHERE `id` = '".$_SESSION['user']['id']."'")); ?> <head> <title>client</title> <link rel="stylesheet" href="LINKS/CLIENT.CSS"> </head> </head> <body> <app-root></app-root> <script> var NitroConfig = { configurationUrl: "LINKS/configuration.json", sso: "{sso}" }; </script> <script src="LINKS/runtime.js" defer></script> <script src="LINKS/polyfills.js" defer></script> <script src="LINKS/vendor.js" defer></script> <script src="LINKS/main.js" defer></script> </body> </html>
this will work, just edit where it says links to your client.css and nitro files.
MAKE SURE your nitro is built.
 

boz

don daddy
Mar 23, 2021
108
32
this is what i use with my revcms and nitro and works perfect:
<?php $userMaster = mysql_fetch_array(mysql_query("SELECT * FROM `users` WHERE `id` = '".$_SESSION['user']['id']."'")); ?> <head> <title>client</title> <link rel="stylesheet" href="LINKS/CLIENT.CSS"> </head> </head> <body> <app-root></app-root> <script> var NitroConfig = { configurationUrl: "LINKS/configuration.json", sso: "{sso}" }; </script> <script src="LINKS/runtime.js" defer></script> <script src="LINKS/polyfills.js" defer></script> <script src="LINKS/vendor.js" defer></script> <script src="LINKS/main.js" defer></script> </body> </html>
this will work, just edit where it says links to your client.css and nitro files.
MAKE SURE your nitro is built.
Wow thanks man i appreciate that! Is there any chance of you uploading the .css you use, thanks again it solved the problem. Is saying WebLG required atm but I’m sure I can sort that.
Post automatically merged:

this is what i use with my revcms and nitro and works perfect:
<?php $userMaster = mysql_fetch_array(mysql_query("SELECT * FROM `users` WHERE `id` = '".$_SESSION['user']['id']."'")); ?> <head> <title>client</title> <link rel="stylesheet" href="LINKS/CLIENT.CSS"> </head> </head> <body> <app-root></app-root> <script> var NitroConfig = { configurationUrl: "LINKS/configuration.json", sso: "{sso}" }; </script> <script src="LINKS/runtime.js" defer></script> <script src="LINKS/polyfills.js" defer></script> <script src="LINKS/vendor.js" defer></script> <script src="LINKS/main.js" defer></script> </body> </html>
this will work, just edit where it says links to your client.css and nitro files.
MAKE SURE your nitro is built.
My nitro is fully built yet I’m getting ‘webLG’ is required on the nitro page, been trying to figure it out all day do you have any idea on why I’m getting it?
 
Last edited:

MrTreiz

New Member
May 24, 2018
3
1
this is what i use with my revcms and nitro and works perfect:
<?php $userMaster = mysql_fetch_array(mysql_query("SELECT * FROM `users` WHERE `id` = '".$_SESSION['user']['id']."'")); ?> <head> <title>client</title> <link rel="stylesheet" href="LINKS/CLIENT.CSS"> </head> </head> <body> <app-root></app-root> <script> var NitroConfig = { configurationUrl: "LINKS/configuration.json", sso: "{sso}" }; </script> <script src="LINKS/runtime.js" defer></script> <script src="LINKS/polyfills.js" defer></script> <script src="LINKS/vendor.js" defer></script> <script src="LINKS/main.js" defer></script> </body> </html>
this will work, just edit where it says links to your client.css and nitro files.
MAKE SURE your nitro is built.
Hey, its not working for me sso ticket isn't showing can someone help me?
 

Users who are viewing this thread

Top