[PlusEmu] Debug problem

Karel

New Member
Messages
8
Likes
0
#1
Hai, i’m pretty new to creating hotels and I set up one (which i’m really proud off XD), but now I want to change some commands. I read about visual studio and debugging, so I tried to do that. Unfortunally, when I debug the emulator, the emulator doesn’t function. I obviously do something wrong, but I can’t figure out what that is. Has anyone else had this problem and can you tell me what to do or if you just know how to fix it tell me?
 
Messages
4,971
Likes
1,115
#2
We aren't mind readers. You can't just say the emulator doesn't function. Screenshots, error logs, details of what you changed, code snippets.
 

Karel

New Member
Messages
8
Likes
0
#3
The emulator says:
[Debug] Handled Packet: [4000] GetClientVersionEvent
[Debug] Unhandled Packet: [3392] BODY:

Visual Studio says (Debug):
'Plus Emulator.exe' (CLR v4.0.30319: DefaultDomain): Loaded 'C:\WINDOWS\Microsoft.Net\assembly\GAC_64\mscorlib\v4.0_4.0.0.0__b77a5c561934e089\mscorlib.dll'. Skipped loading symbols. Module is optimized and the debugger option 'Just My Code' is enabled.
'Plus Emulator.exe' (CLR v4.0.30319: DefaultDomain): Loaded 'C:\Users\Kaj\Desktop\PlusEMU\Release 2\Emulator Source\bin\Debug\Plus Emulator.exe'. Symbols loaded.
'Plus Emulator.exe' (CLR v4.0.30319: Plus Emulator.exe): Loaded 'C:\Users\Kaj\Desktop\PlusEMU\Release 2\Emulator Source\bin\Debug\log4net.dll'. Skipped loading symbols. Module is optimized and the debugger option 'Just My Code' is enabled.
'Plus Emulator.exe' (CLR v4.0.30319: Plus Emulator.exe): Loaded 'C:\WINDOWS\Microsoft.Net\assembly\GAC_MSIL\System.Configuration\v4.0_4.0.0.0__b03f5f7f11d50a3a\System.Configuration.dll'. Skipped loading symbols. Module is optimized and the debugger option 'Just My Code' is enabled.
'Plus Emulator.exe' (CLR v4.0.30319: Plus Emulator.exe): Loaded 'C:\WINDOWS\Microsoft.Net\assembly\GAC_MSIL\System\v4.0_4.0.0.0__b77a5c561934e089\System.dll'. Skipped loading symbols. Module is optimized and the debugger option 'Just My Code' is enabled.
'Plus Emulator.exe' (CLR v4.0.30319: Plus Emulator.exe): Loaded 'C:\WINDOWS\Microsoft.Net\assembly\GAC_MSIL\System.Core\v4.0_4.0.0.0__b77a5c561934e089\System.Core.dll'. Skipped loading symbols. Module is optimized and the debugger option 'Just My Code' is enabled.
'Plus Emulator.exe' (CLR v4.0.30319: Plus Emulator.exe): Loaded 'C:\WINDOWS\Microsoft.Net\assembly\GAC_MSIL\System.Xml\v4.0_4.0.0.0__b77a5c561934e089\System.Xml.dll'. Skipped loading symbols. Module is optimized and the debugger option 'Just My Code' is enabled.
'Plus Emulator.exe' (CLR v4.0.30319: Plus Emulator.exe): Loaded 'C:\Users\Kaj\Desktop\PlusEMU\Release 2\Emulator Source\bin\Debug\MySql.Data.dll'. Skipped loading symbols. Module is optimized and the debugger option 'Just My Code' is enabled.
'Plus Emulator.exe' (CLR v4.0.30319: Plus Emulator.exe): Loaded 'C:\WINDOWS\Microsoft.Net\assembly\GAC_64\System.Data\v4.0_4.0.0.0__b77a5c561934e089\System.Data.dll'. Skipped loading symbols. Module is optimized and the debugger option 'Just My Code' is enabled.
'Plus Emulator.exe' (CLR v4.0.30319: Plus Emulator.exe): Loaded 'C:\WINDOWS\Microsoft.Net\assembly\GAC_MSIL\System.Windows.Forms\v4.0_4.0.0.0__b77a5c561934e089\System.Windows.Forms.dll'. Skipped loading symbols. Module is optimized and the debugger option 'Just My Code' is enabled.
'Plus Emulator.exe' (CLR v4.0.30319: Plus Emulator.exe): Loaded 'C:\WINDOWS\Microsoft.Net\assembly\GAC_MSIL\System.Drawing\v4.0_4.0.0.0__b03f5f7f11d50a3a\System.Drawing.dll'. Skipped loading symbols. Module is optimized and the debugger option 'Just My Code' is enabled.
'Plus Emulator.exe' (CLR v4.0.30319: Plus Emulator.exe): Loaded 'C:\WINDOWS\Microsoft.Net\assembly\GAC_64\System.Transactions\v4.0_4.0.0.0__b77a5c561934e089\System.Transactions.dll'. Skipped loading symbols. Module is optimized and the debugger option 'Just My Code' is enabled.
'Plus Emulator.exe' (CLR v4.0.30319: Plus Emulator.exe): Loaded 'C:\WINDOWS\Microsoft.Net\assembly\GAC_64\System.EnterpriseServices\v4.0_4.0.0.0__b03f5f7f11d50a3a\System.EnterpriseServices.dll'. Skipped loading symbols. Module is optimized and the debugger option 'Just My Code' is enabled.
'Plus Emulator.exe' (CLR v4.0.30319: Plus Emulator.exe): Loaded 'C:\WINDOWS\Microsoft.Net\assembly\GAC_64\System.EnterpriseServices\v4.0_4.0.0.0__b03f5f7f11d50a3a\System.EnterpriseServices.Wrapper.dll'. Skipped loading symbols. Module is optimized and the debugger option 'Just My Code' is enabled.
'Plus Emulator.exe' (CLR v4.0.30319: Plus Emulator.exe): Loaded 'C:\WINDOWS\Microsoft.Net\assembly\GAC_MSIL\System.Management\v4.0_4.0.0.0__b03f5f7f11d50a3a\System.Management.dll'. Skipped loading symbols. Module is optimized and the debugger option 'Just My Code' is enabled.
'Plus Emulator.exe' (CLR v4.0.30319: Plus Emulator.exe): Loaded 'C:\WINDOWS\Microsoft.Net\assembly\GAC_MSIL\System.Numerics\v4.0_4.0.0.0__b77a5c561934e089\System.Numerics.dll'. Skipped loading symbols. Module is optimized and the debugger option 'Just My Code' is enabled.
'Plus Emulator.exe' (CLR v4.0.30319: Plus Emulator.exe): Loaded 'C:\Users\Kaj\Desktop\PlusEMU\Release 2\Emulator Source\bin\Debug\HabboEncryption.dll'. Module was built without symbols.
'Plus Emulator.exe' (CLR v4.0.30319: Plus Emulator.exe): Loaded 'C:\WINDOWS\Microsoft.Net\assembly\GAC_MSIL\mscorlib.resources\v4.0_4.0.0.0_nl_b77a5c561934e089\mscorlib.resources.dll'. Module was built without symbols.
The thread 0x171c has exited with code 0 (0x0).
The thread 0x404 has exited with code 0 (0x0).
The thread 0x1944 has exited with code 0 (0x0).
The thread 0x1e44 has exited with code 0 (0x0).
The thread 0x34c4 has exited with code 0 (0x0).
The thread 0xc4c has exited with code 0 (0x0).
The thread 0x35f4 has exited with code 0 (0x0).
The thread 0x1584 has exited with code 0 (0x0).
The thread 0x2034 has exited with code 0 (0x0).
The thread 0x9fc has exited with code 0 (0x0).
The thread 0x1c54 has exited with code 0 (0x0).
The thread 0x140c has exited with code 0 (0x0).
The thread 0x378 has exited with code 0 (0x0).
The thread 0x2730 has exited with code 0 (0x0).
The thread 0xb8c has exited with code 0 (0x0).
Exception thrown: 'System.ObjectDisposedException' in System.dll
Exception thrown: 'System.ObjectDisposedException' in System.dll
The thread 0x44 has exited with code 0 (0x0).
The program '[13348] Plus Emulator.exe' has exited with code -1 (0xffffffff).

I changed the DisableDiagonalCommand.cs. And tried to edit the language of the message you receive when you are not the room-owner
 
Messages
4,971
Likes
1,115
#6
1557942598978.png

All you have to do is go to Build -> Build Solution

Make sure your settings are Release and Mixed Platforms or Any CPU I believe

1557942640293.png
 

Hypothesis

Web Developer
Messages
234
Likes
101
#10
What do you mean the emulator doesn't function? What about it doesn't function. Does the client not load? Can you not open the emulator? Be specific.
Post automatically merged:

If you really can't find the issue, I can teamviewer you in about 2 hours, i'm at school currently, going to next period.
 

Karel

New Member
Messages
8
Likes
0
#11
The client wont load but i dont see any errors. It’s open and says it’s ready but the client still won’t load
 

Daltron

Web Developer
Messages
172
Likes
54
#12
The client wont load but i dont see any errors. It’s open and says it’s ready but the client still won’t load
Are you stuck on 76%? If so are you on a VPS? If you are then make sure you opened the emulator TCP ports. Are you using the proper Habbo.swf? If you aren't using the one from the release then use that one. Open client.php im assuming your on rev that is, and make sure ALL your paths are linked correctly from config.php and client.php.
 

Karel

New Member
Messages
8
Likes
0
#13
I did some editting in the habbo.swf. Does that matter for the game? The thing I editted is the staffbadge above the avatar.
It is running on localhost btw
Post automatically merged:

I do see the release and mixed platforms, but I can’t find that third button. Is that one important or can I also do thing without that?
 
Last edited:

Daltron

Web Developer
Messages
172
Likes
54
#14
I did some editting in the habbo.swf. Does that matter for the game? The thing I editted is the staffbadge above the avatar.
It is running on localhost btw
Post automatically merged:


I do see the release and mixed platforms, but I can’t find that third button. Is that one important or can I also do thing without that?
Read my post
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top