Findretros 3.0 Voting API Has Broken Since Update!

Rebel

Zabbo Founder (Justin)
Messages
183
Likes
197
#1
Ever since y'all had this update my voting API has been fked.... could someone explain? my voting is coded so when a user logins and goes to any of the pages /me / community etc... they have to vote to see them if they don't they can't access client either. I've coded mine in my global.php (RevCMS) worked fine before update never had a problem. Now it just goes to [ To view this link you must register here. ] and tells my users they have to wait 24 hours to vote again, and keeps bring them to the voting page. I went from 1st on 2nd page to 4th because I've had to disable voting.





@bigdawg @Jeffrey @Sledmore @Wouto
P.S
I have everything set right I don't understand why this is happening.
 
Last edited:

Wess

BYPASSING OVERRIDE
Staff member
FindRetros Moderator
Messages
3,715
Likes
1,944
#2
I've made your post in a thread so everyone can easily find the fix for this once @bigdawg is able to help you.
 

Amazing

WebHost Founder
Messages
141
Likes
19
#4
Hi, you can use a forcevote APi which grabs the user's ip and redirects them depending on if they voted or not, if you need support with this, pm me
 

Small

pinkmangroup
Messages
15
Likes
2
#5
Can you hide websites without a banner until they upload one to reduce clutter? Right now the website is a clusterfuck of blank sites and it looks ugly
 

Rebel

Zabbo Founder (Justin)
Messages
183
Likes
197
#6
Can you hide websites without a banner until they upload one to reduce clutter? Right now the website is a clusterfuck of blank sites and it looks ugly
Agreed to many pages and makes it harder for retros that are active to be seen. Because nine times outta ten the ones without a banner already are just spam pages, or ones that aren't active anymore. So it would make more sense to make them hidden until a banner is uploaded to save the pages from lag from loading unnecessary blank banners.
 

Rebel

Zabbo Founder (Justin)
Messages
183
Likes
197
#8
I remember this fix, change your /vote url to
[ To view this link you must register here. ]

Hope I Helped!
 
Did this fix your problem @Rebel ??
No sadly it didn't but I think I managed to fix it myself, but thank you anyways man appreciate it. Had to redo my /findretros/voted.php file.
 

Jeffrey

Devbest Indian Tech Support
FindRetros Moderator
Messages
1,155
Likes
409
#9
No sadly it didn't but I think I managed to fix it myself, but thank you anyways man appreciate it. Had to redo my /findretros/voted.php file.
If I am correct, i believe the official API works perfectly. You can ignore postback URL until any further announcements by @bigdawg
 

Rebel

Zabbo Founder (Justin)
Messages
183
Likes
197
#12
Changes I made to voted.php that fixed my issue.
Btw my API is different I believe it grabs from global.php so when they login they have to vote. But it still does check /findretros/ folder. Which the one Sledmore I think released only has findretro_config.php and findretros.php, and the
HTML:
    <?php
   
    require_once 'findretros_config.php';
    require_once 'findretros.php';
   
    $FindRetros = new FindRetros();
   
    if($FindRetros->hasClientVoted()) {
   
        echo 'You have voted!';

    }else{
   
        // echo 'You have yet to vote!';

        $FindRetros->redirectClientToVote();
   
    }
Mine is little different from voting API released I believe probably why I had that problem.


Unedited voted.php file.


Edited voted.php with changes made that fixed my issue.
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top